Do you need to find better ways to manage information? Whether the task is keeping up with employees, equipment, or patient care outcomes, an electronic solution may be exactly the help you need. A recent article in CIN Plus discussed how to use Microsoft (MS) Word tables. Although MS Word tables offer a good way to display data, there might be better alternatives such as spreadsheet or database software to manage data. The purpose of this article is to discuss how to use Excel to manage data. Excel, a component of all of the MS Office Suite products, is a simple “flat file” database appearing much like a single sheet of paper or a single table.

You may be thinking, “I thought that spreadsheet software is used to display numbers and perform calculations.” If so, you are correct because the computerized spreadsheet software was originally designed to perform accounting calculations during the 1960s and 1970s. A spreadsheet is a table consisting of rectangles (cells) in the form of columns and rows. Each cell can be uniquely formatted to display text data, numbers, or formulas. Excel treats dates and times as numbers. Those of us who are not accountants quickly saw how spreadsheets could manage data as well as numbers and calculations. MS Excel is a “good enough” data manager for many purposes. The software includes form features for data entry and the ability to create drop-down menus with pre-defined answers to ensure data integrity. Data integrity means that there are pre-defined rules to ensure that data are always entered the same way. Data integrity allows us to query and sort data in meaningful ways.

### PLANNING A DATABASE

You might already have some ideas about the data you want to manage. What questions do you want to have answered? Plan your database carefully before you start the design and construction processes. The following guidelines should help you get started:

- **Classify the data so that they can be grouped and aggregated** (look at the same variable [column data] for many different rows) into meaningful ways. Make sure that the variable has distinct information; for example, separate an address into street, city, state, and zip code and a name into first and last names. The distinct field names allow you to sort data by each field individually or use data in ways not envisioned when the database is originally created.
- **Assure data integrity using predetermined answers whenever possible.** There must be consistency in the way data are entered to ensure that you can extract information and aggregate it.

---

**Key Points:**
- Data formatting/integrity
- Sorting data
- Use data validation features

---

**CONVENTIONS USED IN INSTRUCTIONS**

The screenshots and instructions are given for the Windows operating system (OS), but should be generalizable for the Apple Mac OS. The following conventions are used to simplify instructions.

1. An instruction with words separated by the greater than sign (>) denotes a menu which, when selected, provides another menu. Follow the directions by clicking on the selection from the menu.
2. The term “cursor” indicates the blinking insertion point in a text line.
3. The terms “click on” and/or “select” indicate moving the mouse pointer and clicking using the left mouse button.
4. Using the control key in conjunction with another key is a keyboard shortcut. When you see an instruction `Ctrl+Z`, hold down the Ctrl (control) key, tap the key that follows the plus (+) sign, then release both keys.
5. Items that you should select will be in **boldface**.
6. Items that you need to type will be in *italics*.
7. Drop-down menus are menu boxes with a solid triangle pointing down. Click on the triangle to make a selection from the menu.


- Use the same combinations of characters and terms throughout the database design. For example, decide ahead of time whether or not to use spaces in field names. Once you make a decision, stick to it.
- Create data validation rules to minimize date entry errors. For example, if a field must be a date, create rules for data entry that will allow the user to enter only a date.

A poorly designed database can result in the output of inaccurate information and erroneous conclusions. Effective, thoughtful planning of a database design is a critical first step. Examine the Code Blue events database used in this simple database example for evidence of planning.

### Creating, Editing, and Using Excel as a Simple Database

Databases are simply electronic filing systems that provide us with a way to transform bits of data into meaningful information. For example, think about information a hospital might want to know about Code Blue events (events called to notify a specialized response team of a possible cardiopulmonary arrest). For the purpose of this example, we will use nine pieces of information (or variables) as our headers on the spreadsheet. They are: medical record number, date, time code called, type of arrest, time code ended, survival, discharge date, length of code, and length of stay. To follow this example, launch (open) Excel and follow the directions below.

#### Name a Worksheet and Create Column Headers

When you open Excel, the default file is a workbook that consists of three spreadsheets. We will be working with only the first spreadsheet in the workbook. Double-click on the “Sheet 1” tab at the bottom of the worksheet and rename it Code Blue by typing over Sheet1. It is a good idea to rename a worksheet to make it easy to identify (see Figure 1).

Now you are ready to enter data. Remember that columns run from top to bottom vertically and are labeled using the alphabet. The rows or records run from left to right horizontally and are numbered. To facilitate data management, enter the column headings with the variable names. The variable names are classified as the records or rows. Figure 2 shows the worksheet with the column headings. To create the column headings:

1. Click in the cell A1. Type MRN as an abbreviation for medical record number (see Figure 2).
2. Tap the Tab key to move to cell B1. Type CodeDate.
3. Repeat Step 2 to ender the rest of the column headings: TimeCalled (time code called); ArrestType (type of arrest); TimeEnded (time code ended); Survival (survival); DischargeDate (discharge date); Code-Time (length of code); and LOS (length of stay). Note: You can either leave out spaces or use spaces between words in column headings—just be consistent.

#### Formatting Cells for Data Type

Now that there are some column headings to guide us, let us format the columns for the type of data. When a number is required for a calculation, format that column for numbers. Many medical record numbers are “numbers” but not used in calculations because they only help us identify each record. Thus, a medical record column should be formatted as text. ArrestType and Survival should also be formatted as text as these variables will be words and not numbers. The CodeDate and Discharge Date should be formatted as a Date (you have a variety of formats for dates and times) and both TimeCalled and TimeEnded should be formatted as Time.

To format a group of cells in the column as Text:

1. Right-click on the letter A just above the column heading MRN to highlight the entire column.
2. On the menu, click on Format Cells > Number > Text (see Figure 3).
3. Repeat Steps 1 and 2 for Columns D and F.

To format a group of cells in the column as Date:

1. Right-click on the letter B just above the column heading Date to highlight the column and obtain a menu.
2. On the menu, click on Format Cells > Number > Date. The default formatting is okay.
3. Repeat Steps 1 and 2 for Column G.

To format a group of cells in the column as Time:

1. Right-click on the letter C just above the column heading TimeCalled.
2. On the menu, click on Format Cells > Number > Time. Click on the second choice to use 24-hour time formatting.
3. Repeat Steps 1 and 2 for Column E.
Use Data Validation Features

One of the questions that this flat database needs to answer is how many patients survived the code, how many expired during the code, and how many expired after the code. Formatting the “Survived column” for a particular type of data does not ensure that these answers will be provided. To use data in this manner, there must be consistency in the way that text data are entered. In this example, we have decided to code the data as follows: “Survived” to designate that the patient survived to discharge, “During” to indicate that the patient expired during the code, and “After” to indicate that the patient expired after the code. The column (field in a database) “ArrestType” is another column that needs consistency in how data are entered if we are to know how many of each type of arrest were seen. We decide to use the words “CP” to indicate a Cardiopulmonary arrest, “Cardiac Only” to indicate cardiac arrest only, “Respiratory Only” for an arrest that is only respiratory, and “Not an Arrest” for a code that is not an arrest. To ensure that only these data will be entered, use the online help to learn how to create a list for each of these columns.

We also wish to use this database to answer the question of how long a code took. Although we have formatted both the “TimeCalled” and “TimeEnded” columns as time fields, Excel will allow you to enter a word in these fields. To ensure that only time is entered, you need to use the data validation feature.

1. Select the column TimeCalled.
2. On the menu line, click on Help.
3. Click on data validation lists in the search box.
4. Click on None of the above in the first window.
5. Click on Send and go to the Web. (It may take a few minutes to load.)
6. Select Data Validation 1: Control User Choices with Lists in Excel. (Make sure you select the top line.)
7. Follow the directions.

Although the cell in row 1 already has data that do not meet the criteria you have just stipulated for these cells, it will not be affected by the new settings. Setting data validation does not affect any data that have already been entered. You may wish to experiment with entering messages using the “Input Message” and “Error Alert” tabs. Note that in the “Error Alert” window the default under “style” for validation settings is “Stop.” This selection forces future entries to match what you have set. Experiment with the other two settings. The “Input Message” can be helpful when you need to direct someone to enter specific data. Experiment with that too.

Enter Data and Create Calculated Fields

In this next step, we will create calculated values for length of code and time to discharge, but to make sure that the calculations work, we should enter some data. Enter the data as shown in Figure 4.

After you have entered data, create formulas using the procedures outlined below for the calculated values, LOS and CodeTime columns, and then copy and drag the formulas to the other cells in the column. The cell that is copied is the source cell. The cell receiving the formula is the destination cell. When you copy a formula, Excel automatically adjusts the formula for the new cell location by default. The adjusted reference is known as a relative reference.

Use the online help to learn to use the data validation feature to create a list for the survived and arrest type columns.

1. On the menu line, click on Help.
2. Enter data validation lists in the search box.
3. Click on None of the above in the first window.
4. On the next window, click on None of the above, search for more on the Web.
5. In the box that appears, keep the term data validation in the search box, and click on Send and go to the Web. (It may take a few minutes to load.)
6. Select Data Validation 1: Control User Choices with Lists in Excel. (Make sure you select the top line.)
7. Follow the directions.
To calculate the length of time from code date to discharge date:
1. Click in the first cell (I2) below the header LOS.
2. In cell I2, type the following formula to calculate the time difference between two dates: =DAYS360(B2, G2) and click enter. (The formula subtracts the DischargeDate in cell G2 from the CodeDate in cell B2.)

To calculate the length of code:
1. Click in the first cell (H2) below the header Code-Time.
2. In cell H2, type the following formula to calculate the difference between the code start time and code end time: =TEXT(E2-C2, "h:mm") and click enter. (The formula subtracts the TimeCalled in Cell C2 from the TimeEnded in Cell E2 and then displays the time in hours and minutes.)

To copy the formula to other cells:
1. Right-click on the cell with the formula.
2. Select Copy from the menu.
3. Click on the cell(s) where you want place the formula to highlight them.
4. With the cells highlighted, right-click and select Paste from the drop-down menu.

### Sorting Data

Once you have entered the data, you can sort it to gain some meaning. One easy way to sort data is to use the Data Sort menu. For example, you may be interested in patients’ survival after a Code Blue.

1. Click on the column name Survival.
2. Using the menu bar, select Data > Sort.

You will be asked if you want to expand the selection or continue with the current selection. If you select “Continue with the current selection,” ONLY the selected row will be sorted. This will break the relationship that a given column (field) has with the other data. Selecting “Expand the selection” assures that each line (record) remains intact. If you make a mistake, click the “Undo” icon. Always save the worksheet before you experiment with new features. Then you can always discard the mistake and retrieve the original file. The default is to sort in ascending order. Click the OK button to sort the data.

Once you make the above choice, the window in Figure 5 appears. The boxes for “Then by” refer to secondary and tertiary sorts as described in the May/June 2005 issue. After sorting the data entries, you can easily see that two patients expired during the code and two patients survived until discharge, because the spreadsheet now has like items grouped together. To combine survival with type of arrest, repeat the steps, but this time add “Type of arrest” as a secondary sort.

### Password Protecting Excel Spreadsheets

Much of the data we keep in nursing are confidential and should be password protected. For example, if the data have patient or employee identifiers, it should be password protected. Let’s go ahead and password-protect the file.

1. From the main menu select File > Save As
2. In the Save As window menu, select Tools > General Options (see Figure 6).
3. In the Options window type in a password to open the file. You will get a second window asking you to retype the password.

![FIGURE 5. Sort menu.](image-url)
Play With the Table

If you have time, enter some more data and play with the table. Think about answering questions such as:

- Did any patient code more than one time?
- What was the average length of stay for all patients?
- What was the average length of stay for patients who did not survive until discharge from the hospital?
- What was the percentage of called codes that were not an arrest?

When you ensure data validation and use other Excel data management features, Excel permits you to aggregate data, sort the data, and use formulas to analyze data. Make sure that you consider what questions you want to have answered before you build a database.

CONCLUSION

Excel is one way to manage data electronically. The spreadsheet software provides basic ways to assure data integrity, the ability to calculate values using formulas, the ability to enter data in a form view, and integration features with MS Word. Excel is an easy-to-use data manager tool for most users, but it has limitations. Consider using Excel if you need to manage small amounts of data and perform calculations. Excel has some great features that are beyond the scope of this article, such as charts and pivot tables.

Understand the data management limitations. When you use Excel as a database, you need to first identify the column headings/variables and then enter data. After you enter the data, create any calculated values and copy the formula(s) to the pertinent cells. Although you can enter data in a form view, the form has to be created each time you want to use it. Generally speaking, you don’t have the ability to modify or save a form.

Excel offers a solid beginning step for data management of small projects. The fact that the software package is a component of MS Office Suite makes it readily available. Excel files are easily imported to other software packages such as Word, PowerPoint, and Access (database management system software) and SPSS (statistical software). Go ahead and get started using Excel to manage a small data information project. The benefits of electronic data management far outweigh the pen-and-paper method.

Eventually, you may find that in order to track all the data you want that you need to repeat the data in some of the fields in your database or create more than one field for a subject.

When that happens you are ready to use a relational database such as MS Access that is available either separately, or as part of the MS Office Suite Professional Version.

Jeanne P. Sewell, MSN, RN, is an Assistant Professor at the School of Health Sciences, Georgia College and State University, Milledgeville, GA.

REFERENCES